Registrants Access
Incident Report for LassoCRM
Resolved
This incident has been resolved.
Posted Jan 30, 2020 - 08:26 PST
Identified
The issue has been identified and a fix is being implemented.
Posted Jan 30, 2020 - 08:24 PST
Investigating
Lasso is currently experiencing an issue with accessing registrants. We are investigating it and will provide an update as soon as possible.
Posted Jan 30, 2020 - 06:37 PST
This incident affected: Application.